Adobe released a Mega patch to fix 23 critical vulnerabilities that affected all versions of Adobe Reader and Acrobat for Windows, Mac and UNIX platforms.Adobe strongly recommends users of Adobe Reader 9.3.4 and Adobe Acrobat 9.3.4 to update to latest version Adobe Reader 9.4 & Acrobat 9.4.


Normally both Adobe Reader and Acrobat are set to run automatic update checks on a regular schedule , so by this time you must have installed update. Otherwise you can install the update by choosing Help > Check for Updates.

OR You can downland Adobe Reader 9.4 over here & Adobe Acrobat 9.4 over here.

[ad#ads-inner]